HDL Companion Frequently Asked Questions

Introduction

Q: Which platforms does HDL Companion support?
A: Currently, HDL Companion supports Windows (64 bit) 7/8/10 and Linux (64 bit, Any recent distribution)
Q: Where can I get an evaluation license?
A: If you start HDL Companion without a valid license, the license wizard window will automatically pop-up asking to specify a license file (or license server) or to create a license request. Select the option Create an evaluation license request and press the Finish button. You will be directed to the HDL Works website where you can fill in your details on the license request form. When you press the Summit button the data will be send to HDL Works and you should receive a license within half an hour.
If the procedure above does not work, then you can send an email to with an evaluation license request and the hostid of your system. Or you can contact your local distributor.
NOTE: Every hostid can get an evaluation license only once.
Q: How can I setup my license environment?
A: When HDL Companion can not find a license, it will start with a license wizard window. In this wizard select Specify license file/server and press the Next button. On the second page of this wizard specify the license file or license server and press the Finish button.
You can also start the license wizard by selecting the Tools > License Wizard menu.
Q: Where should I start after the installation of the software?
A: If you are a new user we recommend you to read either the VHDL Tutorial or the Verilog Tutorial,
both included in the installation package.
Q: Where can I find a tutorial?
A: There are 2 tutorials available, one for VHDL and one for Verilog, both included in the installation package.
You can also access them from the Help menu.
Q: Where can I find the user documentation?
A: After starting the tool choose the Help menu. The file is also available from the installation directory.

General

Q: Can I use my existing design in HDL Companion?
A: Yes, you can read your existing designs into HDL Companion. Just drag and drop a directory containing your design into the Global Window of HDL Companion.
Q: Can I share the HDL Companion database between different OS?
A: Yes, HDL Companion does not generate a tool specific database. The HDL code is your source.
Q: Does HDL Companion support mixed VHDL and Verilog for a single project?
A: Yes, you can load a mixed VHDL and Verilog design into HDL Companion.
Q: I lost one of the button bars. How can I get it back?
A: Click with the right mouse button in the button bar area. A window will pop-up with the button bars listed. Click on the name of the bar you lost.
Q: I closed one of the four windows. How can I get it back?
A: All windows have a button in the window button bar. Click on the button of the window you have closed.
Q: How do I place a component declaration or instantiation in the editor?
A: Click with the right mouse button on the appropriate entity or module in the Global Window. Select from the pop-up menu Copy declaration or Copy instance. Go to the editor and do a paste where you want to place the declaration or instantiation.

Project Management

Q: How can I create a new project?
A: Click the Start a new HDL Companion project button. This will close the current project.
Q: How can I add a file or directory to the project?
A: Click the Add files to the project button. In the dialog you can drag the directories and files you want to add to the Selected Objects area.
Q: I added a directory to the project but one file is not used in this project, can I remove this file from the project?
A: You can set this file to unused. Right click the file and select Properties from the pop-up menu. In the properties dialog select Unused. A red cross across the file symbol indicates the unused status of this file. Unused files will not be parsed and you can not view details of these files.
Q: The parser generates errors that are VHDL language version related. Can I set the correct VHDL language version?
A: Yes, default the VHDL version is set to VHDL-93. You can change this in the Options > Project Properties menu. Switch to page VHDL and enable the correct version either VHDL-87 or VHDL-93.
Q: I use synthesis pragma's in my design. The statements between the pragma's are not listed in the Detailed Window. I would like to see these details. Can I change this?
A: Yes, HDL Companion has an option to ignore synthesis pragma's. This option can be found in the Options > Project Properties menu. Switch to page VHDL or Verilog and select Ignore synthesis pragma's check box. Run Compile all HDL files and the statements between pragma's will become visible in the Detailed Window.
Q: I changed an HDL file but the Detailed Window shows the old contents.
A: When you change an HDL file you have to run the Process Modified HDL Files button or Process All HDL Files button. The files will be re-parsed and updates the details shown in the Detailed Window.
Q: Can I create a new library?
A: Yes, click with the right mouse button on the project name in the Object View and select New Library from the pop-up menu. Type a library name in the dialog and press the OK button.

HDL Editor

Q: Can I configure HDL Companion to use my favorite text-editor?
A: Yes, choose the Options > User Options menu, switch to page Editor and enter the details of your favorite text-editor.
Q: Can I change the color settings used in Scriptum?
A: Yes, open from the Scriptum menu bar Options > Languages the language you want to change and select Color. Select the Syntax Item for which you want to change the color and click Color. A window will pop-up with pre-defined colors. Select the color you like.
Q: The syntax coloring does not work for the opened file in Scriptum.
A: The syntax coloring does not work when Scriptum does not recognize the file. Scriptum recognizes a file by the file extension. Open from the Scriptum menu bar Options > Language the language you use in the opened file and select File. Append the extension into the field Recognition without spaces, and re-open the file in Scriptum.
Q: Does Scriptum support identifier expanding?
A: Yes, you can expand an identifier by pressing CTRL+I.
Q: Does Scriptum support language templates?
A: Yes, Scriptum supports language templates for VHDL and Verilog. Press ALT+T and the Language Templates dialog will appear.

Interface to 3rd party tools

Q: I can not find buttons for the 3rd party tools.
A: You have to configure the interface before 3rd party tool buttons will appear in the button bar.
Q: How can I configure the 3rd party interface?
A: Click the EDA Tools Configuration button, or the Tools > EDA Tools Configuration menu. The EDA Tools Configuration dialog will appear. In this dialog you can configure the interface for the tools you are using.
Q: How can I set a tool command, for example to compile with VHDL-93 option?
A: In the EDA Tools Selection dialog select the command for which you want to add an option and type in the Options field the command options you want to use.

Version Management

Q: Does HDL Companion support version management systems?
A: Yes, HDL Companion supports the version management systems CVS, RCS and Subversion.
Q: How can I configure the version management tool?
A: Choose the Options > Project Properties menu. Switch to page Versioning and enable the tool you want to use.
Q: Can I use version management for non-HDL files?
A: Yes, you can use version management for all project files, HDL files and non-HDL files.

Advanced

Q: The VHDL objects are put in a wrong library. Can I move them to the correct library?
A: The Fuzzy Parser investigates in which library an object has to be placed. However you can drag an object to another library in the Object View. When the object has been dropped in the other library all HDL files will be re-parsed. This re-parse can lead to new errors or warnings when you place the object in a wrong library.
Q: Can I change the name of a library?
A: Yes, click with the right mouse button on the library name in the Object View and select Properties from the pop-up menu. Rename the library and press the OK button. All HDL files will be re-parsed. This library renaming can lead to new errors or warnings.
Q: No external tool is configured for a file. Can I configure this?
A: Yes, select Options > File Registration. The File Registration dialog will pop up. Select the Files or Extensions page and press the button New. Fill in the details and the new registration will be added to the list.
Q: Can I change the language templates to satisfy my needs?
A: Yes, the templates are pre-defined in xml files. You can change the xml file to satisfy your needs. You will find them in <install.dir.>/Scriptum/templates.
Q: Can I change the keyboard accelerators?
A: Yes, you can change the accelerators in the file <install.dir.>/scriptum/etc/scriptum_gui.xml.
Home dot Company dot Products dot Sales dot Support dot HDL Corner dot Site Map
Copyright © 2004 - 2017 HDL Works